[wix-users] MSIExec hangs

Walter Dexter wfdexter at gmail.com
Thu May 31 04:43:57 PDT 2018

Do you have a verbose log of the runs when this happens?

What is going on right before the "no longer responding"?

Does that 7D91DEA... match any of the GUIDs in your installer? Or anything
in the system's registry?

I doubt your MSI problem is generically related to PR7, I do
support/development for somewhere around 10K of them (we don't seem to
know) that I've run multiple versions of 3 - 8 different WiX MSIs for
probably 5 years now.

On Tue, May 29, 2018 at 1:16 PM, Fyodor Koryazhkin via wix-users <
wix-users at lists.wixtoolset.org> wrote:

> Hi,
> During installation InstallValidate action hangs with error written to log:
> "Installer is no longer responding". This happens very randomly and not
> consistent on POS Ready 7 systems. (We have thousands of them)
> After restarting the system installation passes OK.
>  I tried to examine the system during the hang:
> 1. There are three Msiexec processes at the time.
> 2. Two of them can be killed manually (that that have command line
> "Embedding 7D91DEA3F4DCC07853AA7459CF4DC003 E Global\MSI0000) and that that
> have my command line)
> 3. The third process cannot be killed manually.
> 4. I tried to take the dump of hung MSI process but that process of taking
> dump also hangs with dump file size staying at zero.
> 5. After the system restarts installation passes OK.
> What can be the problem?
> Thank you
> --
> Regards,
> Fyodor Koryazhkin..
> ____________________________________________________________________
> WiX Toolset Users Mailing List provided by FireGiant
> http://www.firegiant.com/

More information about the wix-users mailing list