[wix-users] Controlling Features in Silent Install

Rob Mensching rob at firegiant.com
Tue Jul 3 10:47:03 PDT 2018

Maintenance mode doesn't re-evaluate the conditions. You must use ADDLOCAL/REMOVE/etc. properties.

 Short replies here. Complete answers over there: http://www.firegiant.com/

-----Original Message-----
From: wix-users <wix-users-bounces at lists.wixtoolset.org> On Behalf Of Ven H via wix-users
Sent: Tuesday, July 3, 2018 12:36 AM
To: WiX Toolset Users Mailing List <wix-users at lists.wixtoolset.org>
Cc: Ven H <venh.123 at gmail.com>
Subject: [wix-users] Controlling Features in Silent Install

I am following the below link (2nd Option) from Fire Giant to control features in my silent install, but somehow, I can't get it to work.


I have 2 features in my Product.wxs and based on the property being passed, I need to control them.

 *<Feature InstallDefault="local" Description="!(loc.AppFeatureDesc)"
Title="!(loc.AppFeatureTitle)" Id="AppFeature" Absent="allow"
Display="expand" AllowAdvertise="no">*
*       <Condition Level="1"><![CDATA[(INSTALL_APP = "1") AND (UILevel <=
*       <Condition Level="0"><![CDATA[(INSTALL_APP = "0") AND (UILevel <=
*       <ComponentGroupRef Id="AppCG" />*
*    </Feature>*

*   <Feature InstallDefault="local" Description="!(loc.DBFeatureDesc)"
Title="!(loc.DBFeatureTitle)" Id="DBFeature" Absent="allow"
Display="expand" AllowAdvertise="no">*
*     <Condition Level="1"><![CDATA[(INSTALL_DB = "1") AND (UILevel <=
*     <Condition Level="0"><![CDATA[(INSTALL_DB = "0") AND (UILevel <=
*     <ComponentGroupRef Id="DbCG" />*
*    </Feature>*

I am invoking the Silent Install command twice for installing the features one at a time.

*msiexec /qn /i MyMSI.msi /l*v App.log INSTALL_APP="1" INSTALL_DB="0"*

The above command installs the App feature properly. Then I run the command again as below to install only DB feature, but it is not installing it.

*msiexec /qn /i MyMSI.msi /l*v DB.log INSTALL_APP="0" INSTALL_DB="1" *

Note: I tried passing INSTALL_APP="1" also in the 2nd command (instead of 0), but that also didn't help. The log file (DB.log), didn't have any errors.

Can anyone please help?

WiX Toolset Users Mailing List provided by FireGiant http://www.firegiant.com/

More information about the wix-users mailing list