[wix-users] MSP not applying a new file

Edwin Castro egcastr at gmail.com
Fri Aug 24 22:48:27 PDT 2018

Sounds like it is working as designed. If you diff 1.1.0 and 1.2.0 to
create a patch, then the patch will only have the difference between 1.1.0
and 1.2.0. I assume both 1.1.0 and 1.2.0 have the file added in 1.1.0 so
that is *not* a difference between 1.1.0 and 1.2.0 and will not appear in
the patch.

If you want a patch to include all changes since 1.0.0, then your base
version for the diff needs to be 1.0.0.

Edwin G. Castro

On Fri, Aug 24, 2018 at 10:04 PM manish duggal via wix-users <
wix-users at lists.wixtoolset.org> wrote:

> Hi
> We had patches released using following information
> 1.0.0 is the baseline MSI
> 1.1.0 is the new MSI. This added a new binary/file. Also created a patch
> by diff of 1.0.0 and 1.1.0
> Till this point, the MSI installation and patch application works fine. We
> can see the new binary/file added to the installation
> Now, we added another version with details as
> 1.2.0 as 2nd new MSI. Created patch by diff of 1.1.0 and 1.2.0
> Now, when we try to deploy patch 1.2.0 directly over 1.0.0 it doesn't
> deploy the new binary/file which was actually added in 1.1.0. I tried to
> open 1.0.0 MSI in orca and then apply 1.2.0 patch and same result i.e. new
> binary/file is not being listed as part of patching
> Interestingly, if I create patch by diff of 1.0.0. and 1.2.0 - I can see
> the file getting applied during patching.
> Is there a possible way to let have patch created by "diff of 1.1.0 and
> 1.2.0" and still able to add the new binary/file when patching 1.0.0? Or
> this is not really feasible?
> Appreciate your help
> ThxManish
> ____________________________________________________________________
> WiX Toolset Users Mailing List provided by FireGiant
> http://www.firegiant.com/

More information about the wix-users mailing list