[wix-users] MSP not applying a new file

manish duggal duggal_sunny at yahoo.com
Fri Aug 24 17:17:10 PDT 2018

We had patches released using following information
1.0.0 is the baseline MSI
1.1.0 is the new MSI. This added a new binary/file. Also created a patch by diff of 1.0.0 and 1.1.0
Till this point, the MSI installation and patch application works fine. We can see the new binary/file added to the installation
Now, we added another version with details as
1.2.0 as 2nd new MSI. Created patch by diff of 1.1.0 and 1.2.0
Now, when we try to deploy patch 1.2.0 directly over 1.0.0 it doesn't deploy the new binary/file which was actually added in 1.1.0. I tried to open 1.0.0 MSI in orca and then apply 1.2.0 patch and same result i.e. new binary/file is not being listed as part of patching
Interestingly, if I create patch by diff of 1.0.0. and 1.2.0 - I can see the file getting applied during patching. 
Is there a possible way to let have patch created by "diff of 1.1.0 and 1.2.0" and still able to add the new binary/file when patching 1.0.0? Or this is not really feasible?

Appreciate your help


More information about the wix-users mailing list