[wix-users] Account behaviour differences

Douglas, Keith (STATCAN) keith.douglas at canada.ca
Tue Oct 25 08:54:47 PDT 2016

I'm trying to figure out why my windows service fails to install on some machines yet manages to register itself with service control manager.

While testing on a VM, I accidentally tried a downgrade, which in our case is supposed to fail. I didn't notice I was doing this as we have the same service (running as System) shutting itself down to do installs of itself if an installer is present in a directory when the service starts. This downgrade was logged as a success, which is exactly what happens if I use SysInternals psexec -s trick to run as System. If I run the package from the administrator account, even with the same /quiet /norestart, the failure is logged in the event log as expected.

The two messages: "Windows Installer reconfigured the product. Product Name: EscalationService20161019143950-ICOS. Product Version: 1.0.5. Product Language: 1033. Manufacturer: Statistics Canada. Reconfiguration success or error status: 0" is what happens when run as System. I get the expected "Product: EscalationService20161019143950-ICOS -- A later version of EscalationService20161019143950-ICOS is already installed. Setup will now exit." logged if run as administrator.

Returning to the original problem ...
On the machines where the install does not take place, *nothing* appears in P&F - previous version, the upgraded version, etc. Yet the service is running, even after restart - since this would brick our transmission application if it weren't, and services.msc does show the relevant registered service. Even more confusingly, since we were logging the install, I used wilogutl to confirm confirmes no errors.

Here are my MajorUpgrade and Service related elements if it matters - always the same across versions:

 <MajorUpgrade DowngradeErrorMessage="A later version of [ProductName] is already installed. Setup will now exit." Schedule="afterInstallInitialize" />

 <ServiceInstall Id="ServiceInstaller" Type="ownProcess" Vital="yes" Name="EscalationService" DisplayName="EscalationService" Description="Used by ICOS CAPI applications to isolate privileged operations." Start="auto" Account="LocalSystem" ErrorControl="ignore" Interactive="no">
        <ServiceDependency Id="Winmgmt" />
<Util:ServiceConfig FirstFailureActionType="restart" SecondFailureActionType="restart" ThirdFailureActionType="restart" ResetPeriodInDays="100" />
  <ServiceControl Id="StartService" Start="install" Stop="both" Remove="both" Name="EscalationService" Wait="yes" />

I have no idea if the two weirdnesses are connected, but in case they are, and to avoid list clutter, I ask both at once:
-       Why does installing as System make a difference in the upgrading, and what other "differences" are there?
-       What could produce the symptoms in the "original problem"?

Any help is much appreciated!

Keith Douglas

Programmer Analyst, Collection Systems Division
Statistics Canada / Government of Canada
Keith.Douglas at canada.ca<mailto:Keith.Douglas at canada.ca> / Tel : 613-854-5589

Programmeur analyste, Division des systèmes de collecte
Statistique Canada / Gouvernenment du Canada
Keith.Douglas at canada.ca<mailto:Keith.Douglas at canada.ca> / Tél :613-854-5589

More information about the wix-users mailing list