[wix-devs] Build wixv4 with VS 2017 RC Community

Andreas Orzyszek andreas.orzyszek at gmail.com
Mon Mar 6 10:54:13 PST 2017

I don't have sandcastle installed on the system.
And the Reference Assemblies exist under C:\Program Files 
(x86)\Reference Assemblies\Microsoft\Framework
In all versions from 4.x until 4.6.2.

I checked the environment variable but it is not set.
In the lastbuild log tells me to better set it:
The SHFBROOT system environment variable was not found.  This variable 
is usually created during installation and may require a reboot.  It has 
been defined temporarily for this process as: 

The other message is about the .net framework ...
SHFB: Error BE0071: Unable to locate information for the project 
framework version 'v4.0.30319' or a suitable redirected version 
on this system.  See error number help topic for details.

I tried to reinstall the Win7 SDK because of it, but I can't select the 
ref assemblies.

I'll reset the system in the next days and then install the win7 sdk 
before VS 2017 maybe that is the way to go.

Am 06.03.2017 um 17:21 schrieb Hoover, Jacob:
> I have it installed on one of my build machines.  If memory serves me correctly, there is an environment variable you have to unset to get it to use the NuGet binaries.  Try setting SFHBROOT to nothing before invoking MSBuild.
> -----Original Message-----
> From: wix-devs [mailto:wix-devs-bounces at lists.wixtoolset.org] On Behalf Of Sean Hall
> Sent: Sunday, March 05, 2017 4:33 PM
> To: WiX Toolset Developer Mailing List <wix-devs at lists.wixtoolset.org>
> Subject: Re: [wix-devs] Build wixv4 with VS 2017 RC Community
> For some reason, I didn't get either of Andreas' emails yesterday afternoon.
> I'm able to build the help files for DTF in wix4 with only VS2017 RC Enterprise, maybe Community doesn't install the required files? Does this folder exist on your machine: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework?
> Do you have Sandcastle installed on your machine? We're using the nuget package, and I remember running into issues when it was installed (but I don't remember exactly what the error was).
> On Sat, Mar 4, 2017 at 10:47 AM, Sean Hall <r.sean.hall at gmail.com> wrote:
>> For the Release build error, what is the actual errors that you are
>> getting?
>> Unfortunately, it is normal for a lot of the tests in v4 (and v3) to
>> be failing. I believe many of those in v4 are due to patching being
>> broken right now.
>> On Sat, Mar 4, 2017 at 10:09 AM, Andreas Orzyszek <
>> andreas.orzyszek at gmail.com> wrote:
>>> Hi,
>>> today I had the time to setup a dev machine and figured out what I
>>> need to select in the VS2017 Setup that it works.
>>> Maybe this could be the first doc for v4 to make it a bit easier for
>>> first time users.
>>> I then wanted to grab a simple bug about a spelling error to get used
>>> to the commit stuff. I never used github or git before.
>>> On the website committers a told to build "Debug", "Release" and run
>>> the tests first.
>>> The normal build finishes without problems, but the Release Build
>>> does not work. Some error in dtf project, but I only changed one line
>>> in the burn engine. I just can't get it to work.
>>> Some help would be nice, maybe someone else has seen this.
>>> I then tried to run the tests but it is getting worse, like 50% are
>>> failing. Are they just not working in v4 or did I miss something?
>>> Thanks,
>>> Andreas
>>> ____________________________________________________________________
>>> WiX Toolset Developer Mailing List provided by FireGiant
>>> http://www.firegiant.com/
> ____________________________________________________________________
> WiX Toolset Developer Mailing List provided by FireGiant http://www.firegiant.com/
> ____________________________________________________________________
> WiX Toolset Developer Mailing List provided by FireGiant http://www.firegiant.com/

More information about the wix-devs mailing list