[wix-users] Extensive "MEF service broker" errors after installing WiX Toolset extension for VS 2022

Rob Mensching rob at firegiant.com
Mon Jul 25 10:35:48 PDT 2022

Could you try Votive v1.0.0.20 from here: https://github.com/wixtoolset/VisualStudioExtension/releases/tag/v1.0.0.20

There was a breaking change in VS2022 that they mitigated in recent VS2022 releases. This build _may_ work around that.

-----Original Message-----
From: wix-users <wix-users-bounces at lists.wixtoolset.org> On Behalf Of William Rummler via wix-users
Sent: Monday, July 25, 2022 10:06 AM
To: wix-users at lists.wixtoolset.org
Cc: William Rummler <wrummler at ara.com>
Subject: [wix-users] Extensive "MEF service broker" errors after installing WiX Toolset extension for VS 2022

Hi all,

I installed the WiX Toolset build tools and the WiX Toolset extension in Visual Studio 2022 (via the Extensions UI in VS). The build tools seemed to install fine. After the installation of the extension, I started Visual Studio again and received several "MEF service broker package" errors on the VS splash screen. After clicking through those, I "continued without code" into the main VS UI and received dozens more of the same error before they stopped. At that point, the windows & panels in VS were unusable, only full of error stack traces instead of their normal content.

To try to eliminate the errors, I performed an installation repair (through the VS installer), which got VS working normally again (and removed the extension). I installed the extension again, and got the same behavior.

Then I tried a full uninstall and reinstall. Same thing, VS worked fine until I installed the extension, then the same errors.

Then I tried VS's "clean uninstall" tool followed by fresh installation of everything, including the VS installer. Same thing again.

(Machine restarts throughout each of these steps.)

I examined the log referenced by the error pop-up, and it included an "access denied" error on the path "C:\PROGRAM FILES\MICROSOFT VISUAL STUDIO\2022\ENTERPRISE\COMMON7\IDE\EXTENSIONS\PHLCC4TT.1T0\extension.packcomponent".

(I also tried running VS as admin, and I encountered no errors at all during VS startup. Unfortunately, I can't run VS as admin day-to-day.)

I checked this access-denied path, and the final component of it doesn't exist. The parent folder does, and it has the following contents:

  *   "C:\Program Files\Microsoft Visual Studio\2022\Enterprise\Common7\IDE\Extensions\phlcc4tt.1t0\catalog.json"
  *   "C:\Program Files\Microsoft Visual Studio\2022\Enterprise\Common7\IDE\Extensions\phlcc4tt.1t0\CertificateInformation.dat"
  *   "C:\Program Files\Microsoft Visual Studio\2022\Enterprise\Common7\IDE\Extensions\phlcc4tt.1t0\extension.vsixmanifest"
  *   "C:\Program Files\Microsoft Visual Studio\2022\Enterprise\Common7\IDE\Extensions\phlcc4tt.1t0\manifest.json"
  *   "C:\Program Files\Microsoft Visual Studio\2022\Enterprise\Common7\IDE\Extensions\phlcc4tt.1t0\WixLogo.png"

Has anyone else seen a problem like this? If so, any comment or help is appreciated. I can provide the log if that might clear anything up.

Also, my work colleague has experienced the same issue, and they resorted to using VS 2019 since the 2019 extension works fine for them there.

Thanks for reading,


William Rummler (he/him)
Employee-owner, Senior Software Engineer

Applied Research Associates, Inc.
100 Trade Centre Dr., Suite 200
Champaign, IL 61820

T: 217.356.4500
F: 217.356.3088


WiX Toolset Users Mailing List provided by FireGiant http://www.firegiant.com/

More information about the wix-users mailing list