[wix-users] supportedFramework versions

William Fisher wfisher at summa.com
Tue Aug 1 12:03:13 PDT 2017

I'm trying to get my installer to run on anything Windows 7 SP 1 all the
way up to Windows 10.  I'm creating a custom bootstrapper.  When I run it
in Windows 10, where I have .NET Framework 4.6.2 installed, it comes up no
problem.  When I run it on Windows 7, where I don't have 4.6.2 installed,
execution fails with the following error:

[045C:0E30][2017-08-01T14:54:09]e000: Error 0x8013101b: Failed to create
the managed bootstrapper application.
[045C:0E30][2017-08-01T14:54:09]e000: Error 0x8013101b: Failed to create UX.
[045C:0E30][2017-08-01T14:54:09]e000: Error 0x8013101b: Failed to load UX.
[045C:0E30][2017-08-01T14:54:09]e000: Error 0x8013101b: Failed while

Google tells me that the proper version of .NET Framework isn't installed,
therefore the installer exe won't run.  Here's my BootstrapperCore.config:

<?xml version="1.0" encoding="utf-8" ?>
    <sectionGroup name="wix.bootstrapper"
      <section name="host"
BootstrapperCore" />
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.6.2" />
    <supportedRuntime version="v2.0.50727" />
    <host assemblyName="ApplicationBootstrapper">
      <supportedFramework version="v3.5" />
      <supportedFramework version="v4.0\Client" />
      <supportedFramework version="v4.0\Full" />

I need it to run on anything from .NET 3.5 to 4.6.2.  Does anyone have any
ideas how to solve that?

Bill Fisher   |  Technical Consultant
[ *m* ] 412.427.9804
wfisher at summa.com
[image: [ l ]] billfishersumma   <https://linkedin.com/in/billfishersumma>
611 William Penn Place
Pittsburgh, PA 15219
summa.com <http://www.summa.com/> [image: Summa] <http://www.summa.com/>

More information about the wix-users mailing list